在线客服:
聚辉科技 聚辉科技
全国服务热线:400-9988-537
您的位置:首页 > 技术支持 > 让phpcms v9内容编辑器支持JavaScript.iframe等脚本语言

让phpcms v9内容编辑器支持JavaScript.iframe等脚本语言

浏览 来源:    作者:admin    时间:2020-06-16 03:06
[摘要]

让phpcms v9内容编辑器支持JavaScript.iframe等脚本语言



在phpcms v9后台默认的内容编辑器中,出于安全考虑,默认是禁止JavaScript脚本的,所以我们在添加文章时,虽然加入了js代码,但实际上并没有起作用,而是以文本形式显示。于是就很多时候是需要修改这一限制,做到在文章内容页也能显示JS代码。

让内容页支持JavaScript,具体修改方法:

从文件caches\caches_model\caches_data\content_input.class.php中找到函数:

function get($data,$isimport = 0) {$this->data = $data = trim_script($data);

修改为:

function get($data,$isimport = 0) {$this->data = $data; //不调用过滤函数

这是网上许多地方都有提到的,其实单单这样设置是不够的,因为仅仅是缓存里面的东西,还需要从根本上改变:

phpcms/modules/content/fields/content_input.class.php找到get函数,按照上面的改法才可以彻底解决这个问题。


案例推荐

热门文章